IT-LIST Digest 22Topics covered in this issue include:  1) Re: Scanning	by "Zulmar A. ACCIOLI DE VASCONCELLOS"   2) problems with itsdk	by ELIAS VALCARCEL TORRES   3) spatial averaging of gray values	by "M. Karthikeyan"   4) RE: Debugging of Plugins	by Don Wilcox   5) Image averaging during Acquire	by "Ian Parkinson"   6) ImageTool Bug/Need help	by MARIETRG@SLUVCA.SLU.EDU  7) frame grabbers	by "M. Karthikeyan"   8) RE: problems with itsdk	by Don Wilcox   9) RE: Image averaging during Acquire	by Don Wilcox  10) RE: ImageTool Bug/Need help	by Don Wilcox  11) gdi errors	by Jose Galvez  12) image capture with DT3155	by "S. robert Hilfer"  13) Re: image capture with DT3155	by Jeff Maxson  14) RE: frame grabbers	by Don Wilcox  15) RE: gdi errors	by Don Wilcox ----------------------------------------------------------------------Date: Mon, 27 May 1996 01:03:32 +0100From: "Zulmar A. ACCIOLI DE VASCONCELLOS" To: it-list@sparky.uthscsa.eduSubject: Re: ScanningMessage-ID: <199605262303.BAA22810@alex.union-fin.fr>Cher M. BIRD,Je vous remercie beaucoup por votre attention! Le logiciel  va =EAtre tres= important pour moi...Merci encore,Zulmar ACCIOLI.Zulmar A. ACCIOLI DE VASCONCELLOS    vzulmar@alex.union-fin.fr      zvasconcellos@msn.com          Paris - FRANCEWWW http://alex.union-fin.fr/usr/vzulmar/index.htm------------------------------Date: Mon, 27 May 1996 12:16:50 +0100 (WET DST)From: ELIAS VALCARCEL TORRES To: it-list@sparky.uthscsa.eduSubject: problems with itsdkMessage-ID: <9605271116.AA20672@alaba.upc.es>hello, i can't compile de sdk. i have tried to include it intomy code but it gives me some compilations error .can any one tell me how can i include the sdk into my code.i'm working with bc 4.5 instead of bc 4.52, can it be the reason ofthe problem?thanks.elias.e-mail:  e4006425@est.fib.upc.es------------------------------Date: Tue, 28 May 1996 13:18:46 -0400From: "M. Karthikeyan" To: IT-LIST@sparky.uthscsa.eduCc: karthm@rpi.eduSubject: spatial averaging of gray valuesMessage-ID: <199605281718.NAA16394@ricketts1a.its.rpi.edu>Hello,I am trying to switch to Image Tool for analysis of interference fringes.The images are monochrome, 512 X 512 pixels, 8 bits per pixel. They consistbasically of alternate dark and light bands. The width of each band is nearlyconstant in the y direction.All I need to do using Image Tool is to get a line profile of a selectedportion of the image in the x direction. However, before I do that, I need tobe able to average the gray values in the y direction over a height of say100 pixels. This procedure is to reduce the noise in the final line profile.I was playing around with IT for a couple of days but couldn't figure out howto do the above.It is, of course, possible to manually get the line profiles for 100different lines and average the resulting gray values but this would beimpractical. If someone knows a better way, please let me know. Thank youvery much.M. KarthikeyanChemical EngineeringRensselaer Polytechnic Institutekarthm@rpi.edu------------------------------Date: Tue, 28 May 1996 17:24:06 -0700From: Don Wilcox To: 'ImageTool List Server' Subject: RE: Debugging of PluginsMessage-ID: <01BB4D39.3E0DFF80@slip29.xroads.com>Sorry for the delay, I am running a little behind.I am currently using Borland C++ v4.52 Integrated Development =Environmentto develop a plugin for ImageTool. However, the plugin fails to work inImageTool due to an ObjectWindows Exception. I have tried using the =32-bitdebugger but have failed in my attempt to load the DLL source code. It =givesme the error message "No symbolic table". Having attempted to relink the =DLLwith debugging information included, along with all optimisations off, I =stillget the same error message!The problem is that the version of ImageTool shipped in the install set =does not have debugging information in it.  If you want to be able to =step through ImageTool's source, you will need to recompile the app.  =The settings in the project file will create debugging information (I =think).However, this is not necessary  You can debug the plug-in without having =symbols in IT.  The steps are as follows:1.  Make sure that you have compiled and linked the plug-in with =debugging information.2.  Strip the symbol table out of the plug-in using tdstrp32:  tdstrp32 -s myplugin.dll3.  Move the symbol file into the directory containing the IT.exe.4.  Run the 32 bit debugger and load IT.  You will get the "No symbol =table" message.5.  Make sure that the directory containing the source for your plug-in =is in the source path option of the debugger.6.  Select Load Module (F3).  From the dialog box, select Load symbols =from the right-hand side.  Pick your plug-in from the file dialog.7.  At this point, you may need to Load Module again to pick yor DLL's =source file.Is there something I am obviously doing wrong? Has anyone else been ableto successfully load the source code to allow debugging of their =plugins?Please helpThanksJ. GlennI hope I got the steps right, this is from memory.Don------------------------------Date: Thu, 30 May 1996 15:22:37 GMT+1030From: "Ian Parkinson" To: IT-LIST@sparky.uthscsa.eduSubject: Image averaging during AcquireMessage-ID: Is it possible to take the average of multiple images during Acquire in Image Tool?RegardsIan ParkinsonDivision of Tissue PathologyInstitute of Medical and Veterinary ScienceFrome RoadAdelaideSouth Australia 5000Australia.------------------------------Date: Thu, 30 May 1996 15:35:12 -0600 (CST)From: MARIETRG@SLUVCA.SLU.EDUTo: IT-LIST@sparky.uthscsa.eduSubject: ImageTool Bug/Need helpMessage-ID: <01I5BLDODTQQC3RL51@SLUVCA.SLU.EDU>#1...  I think I have stumbled on to some kind of bug in ImageTool.  If I do a FIND OBJECTS on some filesw/o using AOI ImageTool detects the 1 class of objects to find and asks me for some valuewhich defaults at 10.  Then it crashes and says "GDI Failure Continue Y/N"...Has anyone else had this unfortunate experience?#2....To get around this problem, I can use the AOI feature in the FIND OBJECT settings....However, I would like to be able to use a square or rectangle as my polygon.  Is there a plug-inor something I can get to create such shapes without having to click at every pointwith the pencil?Let me know!!Thanks very much,Bob------------------------------Date: Thu, 30 May 1996 17:05:50 -0400From: "M. Karthikeyan" To: it-list@sparky.uthscsa.eduSubject: frame grabbersMessage-ID: <199605302105.RAA64143@magritte.its.rpi.edu>Could somebody provide a list of frame grabbers that are supported by ImageTool. Thank you.M. KarthikeyanChemical EngineeringRensselaer Polytechnic Institutekarthm@rpi.edu------------------------------Date: Wed, 29 May 1996 08:50:15 -0700From: Don Wilcox To: 'ImageTool List Server' Subject: RE: problems with itsdkMessage-ID: <01BB4E39.3B9A7020@slip29.xroads.com>hello, i can't compile de sdk. i have tried to include it intomy code but it gives me some compilations error .can any one tell me how can i include the sdk into my code.i'm working with bc 4.5 instead of bc 4.52, can it be the reason ofthe problem?This is most likely the problem.  OWL changed between 4.5 and 4.52.Don------------------------------Date: Thu, 30 May 1996 15:09:19 -0700From: Don Wilcox To: 'ImageTool List Server' Subject: RE: Image averaging during AcquireMessage-ID: <01BB4E3A.6269EF40@slip29.xroads.com>Is it possible to take the average of multiple images during Acquire=20in Image Tool?It is not possible to do the averaging during acquisition; however, you =can make acquire the images to a stack and then use stack averaging to =produce your image.Don------------------------------Date: Thu, 30 May 1996 15:11:57 -0700From: Don Wilcox To: 'ImageTool List Server' Subject: RE: ImageTool Bug/Need helpMessage-ID: <01BB4E3A.6DDEAC80@slip29.xroads.com>#1...  I think I have stumbled on to some kind of bug in ImageTool.  If =I do a FIND OBJECTS on some filesw/o using AOI ImageTool detects the 1 class of objects to find and asks =me for some valuewhich defaults at 10.  Then it crashes and says "GDI Failure Continue =Y/N"...Has anyone else had this unfortunate experience?There has been one other report of crashes in Find Objects.  I am =looking into it.#2....To get around this problem, I can use the AOI feature in the FIND =OBJECT settings....However, I would like to be able to use a square or rectangle as my =polygon.  Is there a plug-inor something I can get to create such shapes without having to click at =every pointwith the pencil?If you hold down the ALT key when you make your first click with the =mouse, IT will draw a rectangle.  If you then hold down the SHIFT key, =the rectangle will be forced to a square.As an aside, all of IT's drawing capabilities are discussed in the help =file and manual under the topic "Selections"Don------------------------------Date: Fri, 31 May 1996 10:59:38 -0700From: Jose Galvez To: IT-LIST@sparky.uthscsa.eduSubject: gdi errorsMessage-ID: <2.2.32.19960531175938.00690444@peseta.ucdavis.edu>Hi all,I am relatively new to Image tool, so please bear with me.  What I want todo with it is have it look at microscopic images that have been labeled withimmuno peroxidase stains, and basically count the labeled cells from theunlabeled cells.  Can IT do this?  Also I was tiring at home on my PC(486dx266 win95 16meg ram) and loaded up the chromosome picture that comeswith it.  I wanted to see how the find objects command worked and I got alot of GDI errors.  Basically they program would not count the chromosomes.Any help would be great.Jose------------------------------------------------------------			Jose Galvez, MD		Department of Pathology, UCDMC		2315 Stockton Blvd. PAT I		Sacramento, CA  95817		jjgalvez@ucdavis.edu-------------------------------------------------------------------------------------------Date: Mon, 3 Jun 1996 13:38:41 -0400 (EDT)From: "S. robert Hilfer" To: image tools Subject: image capture with DT3155Message-ID: I am a new user of IT after years of using the dos version of ImagePro-Plus.  We are using win95 and a DT3155 board and cannot capture images.  Is the board only supported in NT, and if so will support for win95 be available soon?------------------------------Date: Mon, 3 Jun 1996 13:08:41 -0500 (CDT)From: Jeff Maxson To: it-list@sparky.uthscsa.eduSubject: Re: image capture with DT3155Message-ID: Ditto here.  I also am new, using Win95, and noticed that the DT3152 isn't supported yet.  But I also saw that these are both "in the works" (my quote, not theirs).  Any idea of when they will be done?Jeff MaxsonOn Mon, 3 Jun 1996, S. robert Hilfer wrote:> I am a new user of IT after years of using the dos version of > ImagePro-Plus.  We are using win95 and a DT3155 board and cannot capture > images.  Is the board only supported in NT, and if so will support for > win95 be available soon?> ------------------------------Date: Sun, 2 Jun 1996 18:19:22 -0700From: Don Wilcox To: 'ImageTool List Server' Subject: RE: frame grabbersMessage-ID: <01BB51EA.2AC87D00@slip27.xroads.com>Could somebody provide a list of frame grabbers that are supported by =ImageTool. Thank you.Right now, ImageTool only support s the DT3155 frame grabber, although =support for additional grabbers may be provided in the future.  IT is =supposed to provide TWAIN support, but I broke that in the last release. = I hope to get it fixed in the very short-term.Don------------------------------Date: Sun, 2 Jun 1996 18:21:42 -0700From: Don Wilcox To: 'ImageTool List Server' Subject: RE: gdi errorsMessage-ID: <01BB51EA.342D4600@slip27.xroads.com>I am relatively new to Image tool, so please bear with me.  What I want =todo with it is have it look at microscopic images that have been labeled =withimmuno peroxidase stains, and basically count the labeled cells from theunlabeled cells.  Can IT do this?  Also I was tiring at home on my PC(486dx266 win95 16meg ram) and loaded up the chromosome picture that =comeswith it.  I wanted to see how the find objects command worked and I got =alot of GDI errors.  Basically they program would not count the =chromosomes.Any help would be great.ImageTool only provides support for gray-scale imaging, and automatic =partitioning using gray-level intensity.  This is provided using the =Find Objects command.  As you have observed, there is an intermittent =bug in the Find Objects command that causes some users to crash with a =GDI failure.  I am looking into the problem.  Note that not all images =exhibit this error.Don------------------------------End of IT-LIST Digest 22